# Contents of the handout

1. **Classifications** .............................................................................................................. 1  
   - Case Nodes ................................................................................................................... 1  
   - Case Classifications ....................................................................................................... 1  
     - Creating a new Case Classification ............................................................................. 1  
     - Adding an Attribute to a Classification ....................................................................... 2  
     - Adding a Classification to a Node .............................................................................. 2  
     - Importing classification sheets ................................................................................. 2  
   - Source Classifications ................................................................................................... 3  
     - Creating a new Source Classification ...................................................................... 3  
     - Adding an Attribute to a Classification ...................................................................... 3  
     - Adding a Classification to a source .......................................................................... 4  
     - Importing classification sheets .............................................................................. 4

2. **Datasets** ......................................................................................................................... 4  
   - Importing a dataset: The Import Dataset Assistant ......................................................... 4  
   - Auto coding a dataset .................................................................................................... 5  
     - Coding for selected columns (for codable fields) ....................................................... 5  
     - Coding at cases for each value in a column (for codable fields) ............................... 6

3. **Matrix coding queries** .................................................................................................. 7  
   - Creating a new matrix coding query ........................................................................... 7  
   - Saving the preview results as a node matrix .................................................................. 8
1. Classifications

Case Nodes
To create a new Case Node – i.e., to create a node that represents a person or an organization

- Select the source that you want to create a case node for. To select multiple sources, hold down the Command key (⌘) while you click the sources. To select all sources in a list, click the first source in the list, then hold down Shift and click the last source in the list
- Go to the Create Tab, and in the ‘Items’ area, click on “Create As Cases”

OR

- CTRL-click on the source you want to create a case node for
- On the menu that pops up, go to “Create as”, and select “Cases”

Case Classifications
Creating a new Case Classification

- Go to the Create Tab, and in the ‘Classifications’ area, click on ‘Case Classification’
OR

- CTRL-click in Node Classifications List View, and select “New Classification” from the menu

Adding an Attribute to a Classification

- Click on the Case Classification you wish to add the attribute to
- Go to the Create Tab, and in the ‘Classifications’ area, click on ‘Attribute’

OR

- CTRL-click on the Classification you wish to add the attribute to, and select “New Attribute” from the menu

Adding a Classification to a Node

- Click on the Case you want to add the Classification to
- Go to the Home tab, in the ‘Item area’ click on ‘Get Info’
- In the box which comes up, in the ‘Attribute values’, select the classification you want to add.

OR

- CTRL-click on the Case or Cases (you can select more than one case at the same time) you want to add the Classification to.
- In the menu which comes up, go to “Classification”, and then select the Classification you wish to add.

Importing classification sheets

You can import files containing NVivo classification sheet data that were created outside NVivo—for instance, data that was gathered in a Microsoft Excel spreadsheet. However, you must save it to a tab-separated values text file before importing it into NVivo. Once you have your txt file ready:

- On the Data tab, in the ‘Import’ area, select ‘Classification Sheets’
- Follow the instructions in the Assistant to import the classification sheet, in step 2 of the assistant, you can create a new classification, or use an existing one. Then, make sure you check mark the three options, so the attribute from the classification you are importing, are actually created, the classification of existing cases is updated, and finally the attribute values are assigned to your cases (See bellow).

---

1 The full hierarchical name of each source or case must be entered in the first column, as follows
For cases—the hierarchical name includes the folder path, the hierarchical node structure and the name of the node. Folders are separated by two backslashes (\\) and nodes are separated by a single backslash (\). For instance, Cases\\Barbara


- When you are done with the Assistant, click Import

OR

- CTRL-click in Case Classifications List View, and select ‘Import Classification Sheet’
- Follow the instructions in the Assistant to import the classification sheet
- When you are done with the Assistant, click Import

**Source Classifications**

**Creating a new Source Classification**

- Go to the Create Tab, and select ‘Source Classification’

OR

- CTRL-click in Source Classifications List View, and select ‘New Classification’ from the menu

**Adding an Attribute to a Classification**

- Click on the Source Classification you wish to add the attribute to
- Go to the Create Tab, in the ‘Classifications’ area, select ‘Attribute’
OR

- CTRL-click on the Source Classification, and select “New Attribute” from the menu

**Adding a Classification to a source**

- Click on the Source you want to add the Classification to
- Go to the Home tab, in the ‘Item area’ click on ‘Get Info’
- In the box which comes up, in the ‘Attribute values’, select the classification you want to add.

OR

- CTRL-click on the Source you want to add the Classification to.
- In the menu which comes up, go to ‘Get Info’
- In the box which comes up, in the ‘Attribute values’, select the classification you want to add.

OR

- CTRL-click on the Source or Sources (you can select more than one source at the same time) you want to add the Classification to.
- In the menu which comes up, go to “Classification”, and then select the Classification you wish to add.

**Importing classification sheets**

Same process as importing classification sheets for Cases. However, for sources—the hierarchical name includes the folder path and the name of the source. Folders are separated by two backslashes (\\). For instance, Internals\Literature\Books\AIFBN

**2. Datasets**

**IMPORTANT!**

You cannot add to a dataset after you import it, so make sure all the information you need is in the dataset before you import it.

**Importing a dataset: The Import Dataset Assistant**

When you import a dataset – either through the Data tab or by CTRL-clicking in the List View of the folder you’d like to import the dataset to – the Import Dataset Assistant will open.

1. Select the spreadsheet (.xls only) you’d like to import. If the spreadsheet file you’re importing has multiple worksheets, select the worksheets you wish to import (you can only import one worksheet at a time).
NVivo Classifications and Datasets for Mac Users
UBC Research Commons, 2016

2. Specify how dates, times and numbers should be interpreted, and whether the first row of your dataset (i.e., your column headings) contains material that should be used as field names.

3. Specify information about the fields you are importing: what the field name is, whether it should be imported or not, and whether you want it to be a Codable field or a Classifying field. If you have a lot of fields, this might take some time!

4. Give your dataset a name (and a description, if you like), and click ‘Import’.

Auto coding a dataset
Coding for selected columns (for Codable fields)

- Click on the dataset whose columns you want to auto code.
• Go to the Analyze tab, in the ‘Coding’ area click the ‘Auto Code’ button
• In the Auto Code Dataset Assistant,
  1. Select “Code at nodes for selected columns”, and click ‘Next’.
  2. Then select the columns you would like to create as nodes. To add a column, select the column in the “Available columns” list, and click the button. To remove a column, select the column in the “Selected columns” and click the button.
  3. Select the auto coding location, under an existing node, or a new node in which case you will have to provide a name to the node. Preview the location of where the node will be created in the Preview box, click ‘Auto Code’.

Coding at cases for each value in a column (for codable fields)

• Click on the dataset whose columns you want to auto code.
• In the Analyze tab, click the ‘Auto Code’ button
• In the Auto Code Dataset Assistant,
  1. Select “Code at cases for each value in a column”, and click ‘Next’.
  2. Choose the column that contains the cases names that you want to create from the drop-down list. Click ‘Next’.
  3. Then select the codable columns you would like to create as nodes. To add a column, select the column in the “Available columns” list, and click the button. To remove a column, select the column in the “Selected columns” and click the button. Preview the location of where the node will be created, and the name of the parent case node in the Preview box. If you are satisfied with the location and name, click ‘Auto Code’. If you would like to modify the name of the parent case node, or classify cases from classifying columns, click ‘Next’.
  4. Use the ‘Under’ drop-down menu to select a new or existing case. If it is a new case, give the case a name. Click ‘Auto Code’ if you don’t want to classify cases from classifying columns, otherwise:
    ▪ Click ‘Classify cases from classifying columns’
    ▪ Select whether to create a new classification or to use an existing one
    ▪ On attributes, click on to select the attributes from classifying columns, uncheck the columns you don’t want to import. Click ‘Done’

Finally, click ‘Auto Code’
3. Matrix coding queries

Creating a new matrix coding query

To create a new matrix coding query:

- On the Query tab, in the ‘Create’ group, click ‘Matrix Coding’
- Choose where you want to search for coding:
  - ‘All sources’—search for content in all the sources in your project, including externals and memos
  - ‘Selected Items’—restrict your search to selected items
  - ‘Items in Selected Folders’—restrict your search to content in selected folders
- Define the rows of the matrix—under ‘Rows’, click the Add button, then choose one of the following:
  - Select Items, then select the sources or nodes you want to display in rows, and then click Select
  - Select Attribute Values and then select the attribute values you want to display in rows, and then click Select Attribute Values
• Define the columns of the matrix—under **Columns**, click the Add button, then choose one of the following:
  o **Select Items**, then select the sources or nodes you want to display in columns, and then click **Select**
  o **Select Attribute Values** and then select the attribute values you want to display in columns, and then click **Select Attribute Values**

• Click the ‘Run Query’ button at the top of Detail View.

**Saving the preview results as a node matrix**
• Click the ‘Save Results’ button at the top of Detail View
• Enter a name and description for the node matrix
• Click ‘Save Results’